Please select To the mobile version | Continue to access the desktop computer version

ulefone Official Forum

Search
View: 3277|Reply: 5

[Discussion] How-to easy fix for GPS not working

[Copy link]

1

Threads

6

Posts

369

Credits

Intermediate Member

Rank: 3Rank: 3

Credits
369
Post time 2017-2-18 02:40:05 | Show all posts |Read mode

Sign up now, Make more friends, Enjoy with more features, Let you easily Fun Community.

You have to Login for download or view attachment(s). No Account? Register

x
Here's an easy fix for the non-working GPS.

You have to be aware that the GPS problem isn't caused by the Armor having a poor GPS implementation, the real reason is that Android 6 is buggy and one of the worst bugs does affect the GPS. This bug has been listed by Google for so long that I suspect that it will never be fixed in Marshmallow by Google.

Here's how to circumvent the problem and end up with a nicely working GPS:

First, install GPS Connect from the store, you'll need this free tool.

To activate the GPS system, do always the following:

1. Force the phone to use 3G, GPS will not work when using 4G ....

2. Use either performance mode ( GPS and AGPS ) or device only ( GPS ). Keep in mind that AGPS reads positioning data from the network's base stations, thus it consumes more battery and of course data, but produces better accuracy in cities among high buildings.

3. Start positioning

4. Run GPS Connect and choose lock GPS. This enables the GPS to function continually regardless of you doing something else with the phone or the screen to be shutdown/locked. Without this ( or similar ) tools the GPS won't lock on properly to satelites, nor stay activated.

5. Start your navigation application.

Now things work as intended. You have to do these steps every time you want to use the GPS



1

Threads

6

Posts

369

Credits

Intermediate Member

Rank: 3Rank: 3

Credits
369
 Author| Post time 2017-2-18 02:47:38 | Show all posts
NB,

GPS is supposed to work regardless if you are using 4G, 3G or 2G, but Google has messed thing up quite nicely regarding GPS in Marshmallow.....

4

Threads

11

Posts

92

Credits

Member

Rank: 2

Credits
92
Post time 2017-2-20 16:14:02 | Show all posts
This fix is not working!!!

1

Threads

40

Posts

766

Credits

Senior Member

Rank: 4

Credits
766
Post time 2017-2-20 19:37:43 | Show all posts
@Vorlon

Take a look inside this posting:

http://forum.ulefone.com/forum.p ... 40&fromuid=3591

1

Threads

4

Posts

58

Credits

Member

Rank: 2

Credits
58
Post time 2017-3-4 16:58:43 | Show all posts
Finally I succeeded by Engineer mode * # * # 3646633 # * # *
after reading the GPS mode Engineer
does GPS fix even after three days and reboot into 20s
27.02.2017.png
03.03.2017.png
01.03.2017.png

4

Threads

11

Posts

92

Credits

Member

Rank: 2

Credits
92
Post time 2017-3-7 16:24:21 | Show all posts
@Valec:
I would like to ask you something. On last picture 1.3.2017.png you are moving with a speed of 6.2km?
I suppose that stood on the site. This is another issue with GPS, try to navigate, you will be all over the place just not there where you supposed to be. My Armor have the same issue (very quick fix, but very unaccurate and randomly loosing a fix to satelites)...
You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list