Please select To the mobile version | Continue to access the desktop computer version

ulefone Official Forum

Search
View: 880|Reply: 3

[Consulting] Flash error for V4A and ARISE zips in TWRP, please help :/

[Copy link]

1

Threads

2

Posts

27

Credits

Newbie

Rank: 1

Credits
27
Post time 2017-3-9 19:01:02 | Show all posts |Read mode

Sign up now, Make more friends, Enjoy with more features, Let you easily Fun Community.

You have to Login for download or view attachment(s). No Account? Register

x
Edited by applecom1de at 2017-3-9 19:08

Hi Ulefone community,

since I read reviews about Viper4Android I am desperate about getting it to run on my Ulefone Metal. So to make a long story short, I tried for three days (and half of the nights) now but still to no avail.

I followed the instructions by user "zgfg" (huge shoutout to him) and managed to get the phone rooted, but when I flash a zip in TWRP I get an error message "could not find meta-inf/com/google/android/update-binary". Google search brought no relevant results.

Few things that might be noticeable:
- First after the initial root, SuperSu popped no icon on the screen, and I had to open it over the Google-App-Store. I finally re-installed it over the SuperSu settings. I then installed Viper4Android from the Google-App-Store (the one with the chinese letters), and it ran, but I heard no difference whatsoever inspite of of trying out multiple settings (even on "extreme") - definitely (!!!) didn't work. I uninstalled it finally.
- Then, for a flashed version of V4A or the ARISE Sound System stuff, I installed SeLinuxModechanger as apk in order to set mode to permissive, but the app claimed that it gets no root access from SuperSu - however root-access-required apps like BusyBox, Root Explorer, Root Checker and so on had no problem with that. Several root checker apps also specifically confirmed the device to be rooted and SuperSu to work flawlessly.
- I hence installed a terminal app (Termux) and this way managed to set Selinux to "permissive" ("setenforce 0", confirmed by "getenforce" and also by RootChecker). Then when trying to flash always the above mentioned error..
- When trying out the ARISE Deuteronomy zip with the AROMA installer, the installer started but kinda froze (touchscreen didn't work at all, navigation with volume- and power buttons on the second menu page impossible, although working flawlessly on the first page) - ???
- I also did finally unroot via SuperSu and flashed a different SuperSU (2.79) and did the whole thing again until mental breakdown, so, here I am.
- One last thing that might help Android doctors for diagnosis: I had Xposed Framework installed, and installed a few modules (DarkTube, ScreenFilter, Flatstyle etc. to make a quick check if it works), all seemed to install just fine, but again there was no effect, I could open the apps, make the settings etc., but no effect to the Youtube design and so on.

What the heck do I have to do?  

                               
Login/Register to enlarge
  I'm a complete noob in the rooting world and would appreciate any help. Thanks in any case!

15

Threads

341

Posts

1237

Credits

Gold Member

Rank: 6Rank: 6

Credits
1237

Thanksgiving Dayulefone MetalGiveaway Participantsulefone Fan from CroatiaHappy HalloweenUpdate Beta team1K Forum MembersForum Star

Post time 2017-3-9 22:17:35 | Show all posts
First, which ROM version are you using, stock ROM or something else?

Both for Android 6 but also for Android 7, instructions for SuperSU and V4A are given in the thread:
http://forum.ulefone.com/thread-296-1-2.html

As stated there (several other users are using V4A and/or XPosed), use:
SuperSU-v2.79.zip
ViPER4Android_2.5.0.5_guitardedhero.zip

Links to my G-drive with all of them are in the thread as above, with instructions what to and in what order, etc.

For V4A and also for XPosed, SELinux can stay in the Enforcing mode, no need to change.

Now, I don't know, but I think to clean up the pollution, it would be better if you flash again the ROM, then TWRP, and then again install SU, BusyBox and V4A

1

Threads

2

Posts

27

Credits

Newbie

Rank: 1

Credits
27
 Author| Post time 2017-3-13 06:49:33 | Show all posts
Ok so in case it might help someone with similar issues: I wiped the whole thing naked to the bones and flashed Eragon. Works like a charm now

Comments

Glad to see, as suggested you by PM. Eragon still rules, the best ROM for Metal. Only, not maintained and there might be issues with its original drivers for those with devices from the 2nd batch  Post time 2017-3-13 07:49
You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list