Please select To the mobile version | Continue to access the desktop computer version

ulefone Official Forum

Search
View: 1726|Reply: 10

[Consulting] FM Radio with loudspeaker does not work?

[Copy link]

5

Threads

25

Posts

154

Credits

Member

Rank: 2

Credits
154

Thanksgiving Day

Post time 2016-10-27 15:11:58 | Show all posts |Read mode

Sign up now, Make more friends, Enjoy with more features, Let you easily Fun Community.

You have to Login for download or view attachment(s). No Account? Register

x
When the headphones are plugged and the FM Radio is playing, then if the loudspeaker output is selected the sound is no more even when changing back to the headphones output. I must unplug and plug the headphones again to get the sound back.

Is there any way to fix this and get FM Radio sound through the loudspeaker? Thanks.

1

Threads

42

Posts

400

Credits

Intermediate Member

Rank: 3Rank: 3

Credits
400

Thanksgiving DayHappy Halloween

Post time 2016-10-27 18:38:34 From the mobile phone | Show all posts
No, it's the same as on every other phone: it uses the headphone cable as the FM antenna. Without antenna, no signal.

5

Threads

25

Posts

154

Credits

Member

Rank: 2

Credits
154

Thanksgiving Day

 Author| Post time 2016-10-27 18:50:25 | Show all posts
Edited by olefoner at 2016-10-27 18:52

@timar: Yes, I know that it uses the headphone cable as antenna. But if you understand what I wrote it's not an antenna issue.

With the headphone cable as the FM antenna plugged in and selecting the speaker as output the radio doesn't produce any output anymore.

1

Threads

42

Posts

400

Credits

Intermediate Member

Rank: 3Rank: 3

Credits
400

Thanksgiving DayHappy Halloween

Post time 2016-10-27 18:52:51 From the mobile phone | Show all posts
Oh, I see. No idea how to solve that, sorry.

3

Threads

131

Posts

1096

Credits

Gold Member

Rank: 6Rank: 6

Credits
1096

Thanksgiving DayHappy Halloweenulefone Metalulefone Fan from Sweden1K Forum Members

Post time 2016-10-27 19:27:50 | Show all posts
I never tried this one before ...  
But it worked!

After switching to 'speaker' I adjusted volume and all of the sudden it started to work.
----
..//Jocke.Sve

5

Threads

25

Posts

154

Credits

Member

Rank: 2

Credits
154

Thanksgiving Day

 Author| Post time 2016-10-27 20:16:14 | Show all posts
Cool. Thanks!

Seems that both volumes are set independently.

The speaker is quiet and not very loud at full volume though.

15

Threads

341

Posts

1237

Credits

Gold Member

Rank: 6Rank: 6

Credits
1237

Thanksgiving Dayulefone MetalGiveaway Participantsulefone Fan from CroatiaHappy HalloweenUpdate Beta team1K Forum MembersForum Star

Post time 2016-10-27 22:15:06 | Show all posts
See a post #3, btw by @timar, thread
[Consulting] HowTo: Viper4Android (audio enhancements)

Citing:
Btw. if you want to increase the headphone output of your device, you should first do so via the MTK EngineerMode App (no root required). Open it by dialing: *#*#3646633#*#*

In the App, open the "Hardware Testing" tab and choose "Audio" and "Headset Mode". You will immediately notice that the Max Vol. is set to 140 instead of the maximum value of 160. So the first thing you want to do is to change this value to 160 (make sure to tap "Set" after doing so). This will increase the volume of all audio on the headphone output. However, the headphone output for playing media is also limited by the maximum relative volume level. To see what I mean, select "Media" from the "Type" Dropdown and "Level 14" from the "Level" dropdown. The value in the box below this dropdown corresponds to the relative loudness on the chosen loudness rocker level. Set this to 255 for Level 14 to make use of the maximum available output (you may also want to accordingly adjust the levels below to avoid a big jump in loudness).

---

Do the same for Loud Speaker Mode.

Also, instead of opening MTK Engineering mode by dialing the code, install the app under the same name from Google Play

15

Threads

341

Posts

1237

Credits

Gold Member

Rank: 6Rank: 6

Credits
1237

Thanksgiving Dayulefone MetalGiveaway Participantsulefone Fan from CroatiaHappy HalloweenUpdate Beta team1K Forum MembersForum Star

Post time 2016-10-28 05:40:01 From the mobile phone | Show all posts
timar replied at 2016-10-27 11:52
Oh, I see. No idea how to solve that, sorry.

I have increased SpeakerPhone power by MTK Eng Tools as posted earlier today above, screenshot from MTK Eng Tools attached.
I run FM Radio (with headphones attached), switch to Speaker (with Vol increased to the max), and it plays pretty loud.
Go back to headphones, it"s also Ok.
Everything is fine (or am I missing something?)
MTK_Eng_Mode.png

5

Threads

25

Posts

154

Credits

Member

Rank: 2

Credits
154

Thanksgiving Day

 Author| Post time 2016-10-28 05:57:32 | Show all posts
Edited by olefoner at 2016-10-28 05:59

I don't know what MTK Eng Tools are.

What we found is that seems that the first run of the FM Radio you must change the volume in the GUI slider control or the speaker won't work and switching afterwards to the headphones neither until the headphones cable is disconnected and reconnected again.

Once the volume is set the first time both headphones and speaker work as expected.

Still, setting the speaker to maximum volume it's much lower than in other phones.

15

Threads

341

Posts

1237

Credits

Gold Member

Rank: 6Rank: 6

Credits
1237

Thanksgiving Dayulefone MetalGiveaway Participantsulefone Fan from CroatiaHappy HalloweenUpdate Beta team1K Forum MembersForum Star

Post time 2016-10-28 06:28:47 | Show all posts
Edited by zgfg at 2016-10-27 23:38
olefoner replied at 2016-10-27 22:57
I don't know what MTK Eng Tools are.

What we found is that seems that the first run of the FM Radio ...

Have you please read my earlier post today afrernoon:
>Also, instead of opening MTK Engineering mode by dialing the code, install the app under the same name from Google Play

Open Google Play (Android Playstore) and find the application "MTK Engineering Mode", install, run,  go to Hardware  / Audio  / Media and increase numerical values exactly as on the screenshot in my previous post (you must press Set at the end), and LoudSpeaker will become louder (not just for FM Radio, but also for the other apps)
You have to log in before you can reply Login | Register

Points Rules

Quick Reply To Top Return to the list